Logo etsi

ETSI's Bug Tracker

Notice: information submitted on the ETSI issue Tracker may be incorporated in ETSI publication(s) and therefore subject to the ETSI IPR policy.

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007831Ext Pack: Object-oriented features (ES 203 790)[All Projects] Generalpublic30-03-2019 16:0509-01-2020 16:04
ReporterKristóf Szabados 
Assigned ToJens Grabowski 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Summary0007831: Clarification request for OO features (reaching super super class)
DescriptionDo I understand correctly that right now when I wish to reach the super class of a super class I can write this.

type class SubClass extends BaseClass {
  public function f(in integer x) return integer {
    return super.f(x) - 1;
  }
}
type class @final FinalClass extends SubClass {
  public function f(in integer x) return integer {
    return super.super.f(x) + 1; // ???
    // The way to reach BaseClass.f?
  }
}
TagsNo tags attached.
Attached Filesdocx file icon CR7831.docx [^] (126,856 bytes) 06-08-2019 15:17
docx file icon CR7831-v2.docx [^] (127,437 bytes) 07-08-2019 09:35

- Relationships

-  Notes
(0015366)
Jacob Wieland - Spirent (developer)
06-08-2019 08:45

So far, this was not an intended semantical use. This should be discussed.
(0015369)
Kristóf Szabados (manager)
06-08-2019 09:23

STF discussion: super.super should not be allowed (only allow reaching first visible class, not deeper).
(0015377)
Jacob Wieland - Spirent (developer)
06-08-2019 15:17

please review
(0015391)
Kristóf Szabados (manager)
07-08-2019 09:36

updated the functionref in the BNF. Please check.
(0015395)
Jacob Wieland - Spirent (developer)
07-08-2019 12:02

changes are ok

- Issue History
Date Modified Username Field Change
30-03-2019 16:05 Kristóf Szabados New Issue
06-08-2019 08:45 Jacob Wieland - Spirent Note Added: 0015366
06-08-2019 09:23 Kristóf Szabados Note Added: 0015369
06-08-2019 09:24 Kristóf Szabados Assigned To => Jacob Wieland - Spirent
06-08-2019 09:24 Kristóf Szabados Status new => assigned
06-08-2019 15:17 Jacob Wieland - Spirent File Added: CR7831.docx
06-08-2019 15:17 Jacob Wieland - Spirent Note Added: 0015377
06-08-2019 15:17 Jacob Wieland - Spirent Assigned To Jacob Wieland - Spirent => Kristóf Szabados
06-08-2019 15:17 Jacob Wieland - Spirent Status assigned => confirmed
07-08-2019 09:35 Kristóf Szabados File Added: CR7831-v2.docx
07-08-2019 09:36 Kristóf Szabados Note Added: 0015391
07-08-2019 09:36 Kristóf Szabados Assigned To Kristóf Szabados => Jacob Wieland - Spirent
07-08-2019 09:36 Kristóf Szabados Status confirmed => assigned
07-08-2019 12:02 Jacob Wieland - Spirent Note Added: 0015395
07-08-2019 12:02 Jacob Wieland - Spirent Status assigned => resolved
07-08-2019 12:02 Jacob Wieland - Spirent Resolution open => fixed
07-08-2019 12:02 Jacob Wieland - Spirent Assigned To Jacob Wieland - Spirent => Jens Grabowski
09-01-2020 16:04 Jens Grabowski Status resolved => closed


MantisBT 1.2.14 [^]
Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker