Logo etsi

ETSI's Bug Tracker

Notice: information submitted on the ETSI issue Tracker may be incorporated in ETSI publication(s) and therefore subject to the ETSI IPR policy.

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0007855Ext Pack: Object-oriented features (ES 203 790)[All Projects] Generalpublic07-08-2019 12:0909-01-2020 16:04
ReporterAxel Rennoch 
Assigned ToKristóf Szabados 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionno change required 
PlatformOSOS Version
Summary0007855: BNF for ClassMember should not allow more than one ConstructorDef
DescriptionIn section A.3 the TTCN-3 syntax BNF production allows more than one instance of ConstructorDef.

Since section 5.1.1.5 introduces one constructor only the BNF rules need to be corrected.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0015400)
Jacob Wieland - Spirent (developer)
07-08-2019 12:44

This is covered by the scoping rules. The constructor introduces a name create and two definitions of the same name in the same scope are not allowed.

Therefore, no BNF change is necessary.

Also, it would not be easy to formulate this on the BNF level.
(0015437)
Kristóf Szabados (manager)
08-08-2019 14:29

STF discussion: not necessary to restrict syntactically, the check is easier on semantic level.

- Issue History
Date Modified Username Field Change
07-08-2019 12:09 Axel Rennoch New Issue
07-08-2019 12:44 Jacob Wieland - Spirent Note Added: 0015400
08-08-2019 14:29 Kristóf Szabados Note Added: 0015437
08-08-2019 14:30 Kristóf Szabados Status new => resolved
08-08-2019 14:30 Kristóf Szabados Resolution open => no change required
08-08-2019 14:30 Kristóf Szabados Assigned To => Kristóf Szabados
09-01-2020 16:04 Jens Grabowski Status resolved => closed


MantisBT 1.2.14 [^]
Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker